サイトが表示されないのは・・・

前述のサイト、
会社設立サイト
が、IE6から見られない原因として、今現在考えられるのは、エンコードをIE6が、”日本語(シフト JIS)”を自動選択してしまうからみたいです。(私が調べた範囲では、これくらいしか分かりません><)
表示→エンコードはどうなっていますでしょうか?
自動選択をクリックしてみてください。それでもダメなら直接、Unicode(UTF-8)をクリックしてみてください。
HTMLでエンコードはちゃんと、「utf-8」を使いますよ!と宣言しているのに、なぜ「シフト JIS」を選択してしまうのか、私には分かりません。
リニューアルする前は、シフト JISを使っていて、「見られない」というご報告はありませんでしたので、やっぱりココだろうなぁ・・・
ココまでの過程で、「utf-8」で作っているので、「シフト JIS」に変えると全ページ文字化けor真っ白の可能性が!; ̄ロ ̄)!
作り直す元気が今の所ないので、いましばらく静観してみようと思います。
でも、私のもう一台のPC(IE6)からは表示されるのはなぜだろう・・・?

7 thoughts on “サイトが表示されないのは・・・

  1. 2台のPCにIE6とIE7が入ってます。
    まずIE7、
    こちらは今までトップページだけが見れませんでした。他のページは Yahoo!Days から辿ると見ることができていました。
    先ほど設定を確かめたところ、「シフトJIS」になっていたため「自動選択」に切り替えたところ、「UTF-8」が選択されトップも見ることができるようになりました。 
    次にIE6、
    設定;自動選択で「子連れ」は「EUC」が選択され、また「会社設立」は「UTF-8」が選択され見ることができます。
    (このPCからこれまで「会社設立」を見ようとしなかったため、トップはまだ完成していないかと思っていました、アホですね!)
    要するに、「IE6」だろうが「IE7」だろうが「自動選択」にしていると見ることができる、
    というのが私のPCでの検証結果です。
    考えられるのは、IE6のヴァージョンぐらいですね。因みに私のは「6.0.2900.2180」、「SP2」です。

  2. レオさん、検証とご報告ありがとうございます!
    えっ!
    今までトップが表示されていなかった; ̄ロ ̄)!
    どおりで、解析を見てみると、直帰率が高かったんです。
    真っ白なら、すぐ違うページに行きますよね。
    でも、いちいちエンコードを変えなきゃいけないサイトなんて・・・_| ̄|○ ガックシ・・・
    やっぱり、餅は餅屋かしら。

  3. あやちゃ~ん
    こちらIE7です。
    ブログを自動選択にしてから、ページリンクをクリックすると見られます。
    ブログの自動選択を外してから、ページリンクをクリックすると真っ白です。
    真っ白のページは1度自動選択を外してから、再度自動選択にしないとutf-8に行きません。
    結局IEが6でも7でも同じなのかな?
    ヒマがあったら解決方法調べときます。

  4. 確かにエンコードを「自動選択」にすると
    表示されますね
    私は通常文字化けを防ぐために"shift JIS"にしてあるので
    真っ白だった訳です
    しかし面倒な話ですね
    ともあれデザインも「ご神影」も
    とても綺麗でいいと思いますよ
    ますますのご発展を願っております

  5. オヤジさんご紹介のページを見てきました。
    「title タグよりも前に meta Content-Type タグをもってくる」
    すなわち、
    「文字コード宣言より手前に日本語を書かない」
    (http://www.mozilla.gr.jp/standards/webtips0022.html)で解決ですかね?
    ヴァージョンなんか全然関係ないでしたね。
    勉強になりました。

  6. あやちゃ~ん
    ワイドの問題、右メニューも指摘するまでもなく、どんどん解決し、進化し続けていますね。
    よかったね。
    私のようなド素人のほうが雑念なく、問題解決ができるのかも。
    要は気迫ですね。(^^;

Comments are closed.